ants/shell.nix
2024-04-09 16:12:01 +02:00

38 lines
622 B
Nix

{
pkgs ? import <nixpkgs> { },
lib,
}:
let
packages = with pkgs; [
rust-analyzer
rustfmt
clippy
clang
mold
nixfmt-rfc-style
pkg-config
libGLU
libGL
libxkbcommon
wayland
# Only needed for X11
xorg.libX11
xorg.libXcursor
xorg.libXrandr
xorg.libXi
];
in
pkgs.mkShell {
# Get dependencies from the main package
inputsFrom = [ (pkgs.callPackage ./default.nix { }) ];
nativeBuildInputs = packages;
buildInputs = packages;
env = {
LIBCLANG_PATH = "${pkgs.libclang.lib}/lib";
LD_LIBRARY_PATH = "${lib.makeLibraryPath packages}";
};
}