rimworld-mod-template/flake.nix
2024-04-16 09:26:30 +02:00

49 lines
1.3 KiB
Nix

{
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
flake-parts.url = "github:hercules-ci/flake-parts";
systems.url = "github:nix-systems/default";
# Dev tools
treefmt-nix.url = "github:numtide/treefmt-nix";
};
outputs =
inputs:
inputs.flake-parts.lib.mkFlake { inherit inputs; } {
systems = import inputs.systems;
imports = [ inputs.treefmt-nix.flakeModule ];
perSystem =
{
config,
self',
pkgs,
lib,
system,
...
}:
{
# Rust dev environment
devShells.default = pkgs.mkShell {
inputsFrom = [ config.treefmt.build.devShell ];
nativeBuildInputs = with pkgs; [
dotnet-sdk_8
libxslt
];
shellHook = ''
DOTNET_ROOT="${pkgs.dotnet-sdk_8}";
'';
};
# Add your auto-formatters here.
# cf. https://numtide.github.io/treefmt/
treefmt.config = {
projectRootFile = "flake.nix";
programs = {
nixpkgs-fmt.enable = true;
csharpier.enable = true;
nixfmt-rfc-style.enable = true;
};
};
};
};
}